Repository navigation
Enforce patched PHP runtimes and Moodle 4.3+ security baseline - #14
Merged
Merged
Conversation
This branch was successfully deployed
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Enforce branch-specific PHP minimums 8.2.35, 8.3.36, 8.4.27 and 8.5.12 for CVE-2026-109618/CVE-2026-109619. Reject PHP 8.1 and older, Moodle below 4.3, incompatible pairs and unverified branches. Moodle 4.3 is included; PHP 8.5 has no enabled Moodle pair yet. Remove obsolete templates and pin patched host/standalone bases by digest.
A shared policy guards build/startup and lifecycle operations. Activation/restore validate actual Moodle source against saved metadata and probe PHP before startup/import; cron preserves the image guard. The Python adapter refuses pre-policy deployment toolkits while retaining migration backup/diagnostic access. Fix PHP 8.2 stdin database-probe diagnostics using fixed, redacted stderr messages. Document existing-site migration, persistent AI rules and obsolete 1.2.0 artifacts. VERSION 1.2.1 is a candidate, not evidence of publication.
Validation on security source
531c341e9e15cdb0eead21fd1663b1aa7f5dbfc0:Existing installations/data are not automatically migrated. No production deployment, live Kubernetes rollout or multi-architecture verification is claimed. Docker Hub/PyPI 1.2.1 publication has not been performed; the published 1.2.0 PHP runtime predates this policy.