Skip to content
This repository was archived by the owner on Jun 18, 2022. It is now read-only.
This repository was archived by the owner on Jun 18, 2022. It is now read-only.

Unable to connect to convoy.sock #214

Description

@stowns

When starting up docker engine on rhel7.

level=warning msg="Unable to connect to plugin: /var/run/convoy/convoy.sock/Plugin.Activate: Post http://%2Fvar%2Frun%2Fconvoy%2Fconvoy.sock/Plugin.Activate: dial unix /var/run/convoy/convoy.sock: connect: no such file or directory, retrying in 1s
convoy info

{
"General": {
	"Root": "/var/lib/rancher/convoy",
	"DriverList": [
		"devicemapper"
	],
	"DefaultDriver": "devicemapper",
	"MountNamespaceFD": "",
	"IgnoreDockerDelete": false,
	"CreateOnDockerMount": false,
	"CmdTimeout": ""
},
"devicemapper": {
	"DataDevice": "/dev/mapper/vg_docker-thinpool_v",
	"DefaultVolumeSize": "107374182400",
	"Driver": "devicemapper",
	"Filesystem": "ext4",
	"MetadataDevice": "/dev/mapper/vg_docker-thinpoolmeta_v",
	"Root": "/var/lib/rancher/convoy/devicemapper",
	"ThinpoolBlockSize": "2097152",
	"ThinpoolDevice": "/dev/mapper/convoy-pool",
	"ThinpoolSize": "633507676160"
}
}

/var/run/convoy/convoy.sock exists. I'm not sure if this is a permissions issue or?

ls -l /var/run/convoy/
total 0
srwxr-xr-x 1 root root 0 Jun  6 17:08 convoy.sock

Convoy log as a couple errors in it

level=error msg="Handler not found: POST /VolumeDriver.Capabilities" pkg=daemon
...
level=error msg="http server erroraccept unix /var/run/convoy/convoy.sock: use of closed network connection" pkg=daemon

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions