In the copy_media_files step's Cleanup phase, the ConfigMap that was created is correctly removed. However, it is not removed from the VM's list of storage volumes. When keep_vm = false this isn't a problem because the VM is removed entirely. However, when keep_vm = true the VM definition is left in a state from which it is unable to start, as it still has the reference to the now-deleted ConfigMap.
As part of the cleanup the ConfigMap should be removed from the VM's volume list so that the VM is left in a clean state.
In the
copy_media_filesstep's Cleanup phase, the ConfigMap that was created is correctly removed. However, it is not removed from the VM's list of storage volumes. Whenkeep_vm = falsethis isn't a problem because the VM is removed entirely. However, whenkeep_vm = truethe VM definition is left in a state from which it is unable to start, as it still has the reference to the now-deleted ConfigMap.As part of the cleanup the ConfigMap should be removed from the VM's volume list so that the VM is left in a clean state.