Skip to content

Upgrade to release v3.0.0 fails #211

Description

@escuco

I'm not able to perform the upgrade to v3.0.0 via the web backend.
When upgrading from v2.9.2 through the web backend a 404 not found is thrown out directly after the backup process at this url: https://my-domain/update?preparing.

After that, I can access the web backend manually and the upgrade is still available.

All upgrades before this one went fine.

Activity

  1. JulianPrieber commented on Nov 15, 2022

    @JulianPrieber
    Member

    This should be an easy fix.
    During the update, the advanced config entry custom_url_prefix cannot be empty.
    Just enter anything there before the update. After the update, you can empty the entry again.

    This error will not appear when update from 3.0.0 to future versions.

    Hope this helps 👍

  2. root9191 commented on Nov 15, 2022

    @root9191

    My Update also failed and now i only get the Maintenance Message:

    Maintenance Mode
    We are performing scheduled site maintenance at this time.
    Please check back with us later.
    

    The custom_url_prefix looks like this:
    'custom_url_prefix' => '+',
    And in the .env File the Maintenance Mode is "false".
    Could you help me out here?

  3. JulianPrieber commented on Nov 15, 2022

    @JulianPrieber
    Member

    In your storage folder, there is a file called "MAINTENANCE". If you delete that, you can get out of the maintenance mode.

  4. root9191 commented on Nov 15, 2022

    @root9191

    That worked to get out of the Maintenance Mode, thanks!
    The Parameter now looks like this, but the Update still fails:
    'custom_url_prefix' => 'test',
    Bildschirmfoto 2022-11-15 um 18 20 39

  5. JulianPrieber commented on Nov 15, 2022

    @JulianPrieber
    Member

    That means your page cannot migrate the new database entries.

    This can be caused if PHP isn't allowed to run system commands.

    There are a few ways of solving this. The easiest would be if you have shell access to your LLC instance.
    Can you run system commands in your setup?

  6. root9191 commented on Nov 15, 2022

    @root9191

    Ok i understand. Unfortunately i cannot access LLC via shell.
    It is hosted by hosttech and there i can only access via Webbrowser or FTP.

  7. JulianPrieber commented on Nov 15, 2022

    @JulianPrieber
    Member

    That explains why the update fails. The updater cannot change database entries on pretty much any hosting provider.

    The easiest way would be to upload the database from the manual update version, but this would effectively reset your instance.

    Otherwise, you'd have to find a way to add the new database entries manually.

  8. root9191 commented on Nov 15, 2022

    @root9191

    What if i download the Database and add it locally and then upload it again?

  9. JulianPrieber commented on Nov 15, 2022

    @JulianPrieber
    Member

    You could download your database, put it in a local instance and run the database seeder of the updater (update?finishing) then upload it again.

  10. escuco commented on Nov 15, 2022

    @escuco
    Author

    Hello!

    This should be an easy fix. During the update, the advanced config entry custom_url_prefix cannot be empty. Just enter anything there before the update. After the update, you can empty the entry again.

    That did the trick! Thank you so much.

    Cheers!

  11. locked and limited conversation to collaborators on Nov 15, 2022
  12. converted this issue into a discussion #212 on Nov 15, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions