Repository navigation
Upgrade to release v3.0.0 fails #211
Description
Activity
This should be an easy fix.
During the update, the advanced config entrycustom_url_prefixcannot be empty.
Just enter anything there before the update. After the update, you can empty the entry again.This error will not appear when update from 3.0.0 to future versions.
Hope this helps 👍
Reacted by Jan KlompMy Update also failed and now i only get the Maintenance Message:
Maintenance Mode We are performing scheduled site maintenance at this time. Please check back with us later.The custom_url_prefix looks like this:
'custom_url_prefix' => '+',
And in the .env File the Maintenance Mode is "false".
Could you help me out here?In your storage folder, there is a file called "MAINTENANCE". If you delete that, you can get out of the maintenance mode.
Reacted by rootThat means your page cannot migrate the new database entries.
This can be caused if PHP isn't allowed to run system commands.
There are a few ways of solving this. The easiest would be if you have shell access to your LLC instance.
Can you run system commands in your setup?Ok i understand. Unfortunately i cannot access LLC via shell.
It is hosted by hosttech and there i can only access via Webbrowser or FTP.That explains why the update fails. The updater cannot change database entries on pretty much any hosting provider.
The easiest way would be to upload the database from the manual update version, but this would effectively reset your instance.
Otherwise, you'd have to find a way to add the new database entries manually.
What if i download the Database and add it locally and then upload it again?
You could download your database, put it in a local instance and run the database seeder of the updater (update?finishing) then upload it again.
Hello!
This should be an easy fix. During the update, the advanced config entry
custom_url_prefixcannot be empty. Just enter anything there before the update. After the update, you can empty the entry again.That did the trick! Thank you so much.
Cheers!
Reacted by Julian PrieberReacted by Julian Prieber- locked and limited conversation to collaborators
on Nov 15, 2022

I'm not able to perform the upgrade to v3.0.0 via the web backend.
When upgrading from v2.9.2 through the web backend a
404 not foundis thrown out directly after the backup process at this url:https://my-domain/update?preparing.After that, I can access the web backend manually and the upgrade is still available.
All upgrades before this one went fine.