Installer: Could not create temporary file in directory "config/params" #2292
Shlink versionshlink4.3.1_php8.2_dist PHP version8.2 How do you serve ShlinkSelf-hosted Apache Database engineMariaDB Database versionmysql Ver 15.1 Distrib 10.5.22-MariaDB, for Linux (x86_64) using EditLine wrapper Current behaviorAt the end of running the installer with I have no currently made it past this issue so am unable to attempt hosting with apache/php. Expected behaviorI expect the config file to be saved, or at least a detailed message explaining the issue. Perhaps even a dump of the file that would be saved, so I can save it. Minimum steps to reproduceRockyLinux 9.5. Download latest distrib zip, unzip in a new user account, run the installer. I see no indication from audit.log that this request was blocked, am running as the newly created user, and am also able to create/modify files in the unzipped directory area. |
Replies: 1 comment 4 replies
|
This means the system user does not have write permissions in Shlink directory |


Thanks, but that wasn't it this time. After researching another post, the issue was my working directory. Apparently, you need to be sitting at install root, not inside the vendor/bin directory. But the program doesn't let you know when it fails. Weird.
But again thanks.